// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([\w\.]+):([\w\-]+):(\w+).*:([\w\.]+):").unwrap();
let string = "org.eclipse.aether:aether-impl:jar:0.9.0.M2:compile
com.google.code.findbugs:annotations:jar:3.0.0:compile
org.sonatype.sisu:sisu-guice:jar:no_aop:3.1.0:compile";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}