package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\w\.]+):([\w\-]+):(\w+).*:([\w\.]+):`)
var str = `org.eclipse.aether:aether-impl:jar:0.9.0.M2:compile
com.google.code.findbugs:annotations:jar:3.0.0:compile
org.sonatype.sisu:sisu-guice:jar:no_aop:3.1.0:compile`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}