re = /([\w\.]+):([\w\-]+):(\w+).*:([\w\.]+):/
str = 'org.eclipse.aether:aether-impl:jar:0.9.0.M2:compile
com.google.code.findbugs:annotations:jar:3.0.0:compile
org.sonatype.sisu:sisu-guice:jar:no_aop:3.1.0:compile'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end