import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\w\\.]+):([\\w\\-]+):(\\w+).*:([\\w\\.]+):";
final String string = "org.eclipse.aether:aether-impl:jar:0.9.0.M2:compile\n"
+ "com.google.code.findbugs:annotations:jar:3.0.0:compile\n"
+ "org.sonatype.sisu:sisu-guice:jar:no_aop:3.1.0:compile";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}