const regex = /([\w\.]+):([\w\-]+):(\w+).*:([\w\.]+):/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\w\\.]+):([\\w\\-]+):(\\w+).*:([\\w\\.]+):', 'g')
const str = `org.eclipse.aether:aether-impl:jar:0.9.0.M2:compile
com.google.code.findbugs:annotations:jar:3.0.0:compile
org.sonatype.sisu:sisu-guice:jar:no_aop:3.1.0:compile`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}