#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[a-zA-Z0-9._%+-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,4}"
Local $sString = "br.uno.lesi.eur@gmail.com" & @CRLF & _
"brunolesieur@gmail.com" & @CRLF & _
"bruno.lesieur@gmail.com" & @CRLF & _
".brunolesieur@gmail.com" & @CRLF & _
"brunolesieur.@gmail.com" & @CRLF & _
"bru..no.lesieu..r@gmail.com" & @CRLF & _
"bruno.lesieur+divers-truc-ici@gmail.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")