$re = '/[a-zA-Z0-9._%+-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,4}/';
$str = 'br.uno.lesi.eur@gmail.com
brunolesieur@gmail.com
bruno.lesieur@gmail.com
.brunolesieur@gmail.com
brunolesieur.@gmail.com
bru..no.lesieu..r@gmail.com
bruno.lesieur+divers-truc-ici@gmail.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);