import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z0-9._%+-]+@[a-zA-Z0-9.-]+\\.[a-zA-Z]{2,4}";
final String string = "br.uno.lesi.eur@gmail.com\n"
+ "brunolesieur@gmail.com\n"
+ "bruno.lesieur@gmail.com\n"
+ ".brunolesieur@gmail.com\n"
+ "brunolesieur.@gmail.com\n"
+ "bru..no.lesieu..r@gmail.com\n"
+ "bruno.lesieur+divers-truc-ici@gmail.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}