const regex = /[a-zA-Z0-9._%+-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,4}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-zA-Z0-9._%+-]+@[a-zA-Z0-9.-]+\\.[a-zA-Z]{2,4}', 'g')
const str = `br.uno.lesi.eur@gmail.com
brunolesieur@gmail.com
bruno.lesieur@gmail.com
.brunolesieur@gmail.com
brunolesieur.@gmail.com
bru..no.lesieu..r@gmail.com
bruno.lesieur+divers-truc-ici@gmail.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}