package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-zA-Z0-9._%+-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,4}`)
var str = `br.uno.lesi.eur@gmail.com
brunolesieur@gmail.com
bruno.lesieur@gmail.com
.brunolesieur@gmail.com
brunolesieur.@gmail.com
bru..no.lesieu..r@gmail.com
bruno.lesieur+divers-truc-ici@gmail.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}