// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[a-zA-Z0-9._%+-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,4}").unwrap();
let string = "br.uno.lesi.eur@gmail.com
brunolesieur@gmail.com
bruno.lesieur@gmail.com
.brunolesieur@gmail.com
brunolesieur.@gmail.com
bru..no.lesieu..r@gmail.com
bruno.lesieur+divers-truc-ici@gmail.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}