# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<span.*>(.*)<\\/span>/$1/g;t' <<< "<span class=\"booking-id-value\">U166097</span>"