$re = '/<span.*>(.*)<\/span>/';
$str = '<span class="booking-id-value">U166097</span>';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;