const regex = /<span.*>(.*)<\/span>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<span.*>(.*)<\\\/span>', 'g')
const str = `<span class="booking-id-value">U166097</span>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);