#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<span.*>(.*)<\/span>"
Local $sString = "<span class="booking-id-value">U166097</span>"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)