import Foundation
let pattern = #"<span.*>(.*)<\/span>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<span class="booking-id-value">U166097</span>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)