using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span.*>(.*)<\/span>";
string substitution = @"$1";
string input = @"<span class=""booking-id-value"">U166097</span>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}