#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Event:\s+(?|\S+\s+\S+\s+(\S+)|(Started Flapping))$"
Local $sString = "Input 1:" & @CRLF & _
"Event: Started Flapping" & @CRLF & _
"" & @CRLF & _
"Regex 1:" & @CRLF & _
"" & @CRLF & _
"Output 1:" & @CRLF & _
"Started Flapping" & @CRLF & _
"" & @CRLF & _
"Input 2:" & @CRLF & _
"Event: CRIT -> OK" & @CRLF & _
"Regex 2:" & @CRLF & _
"^Event:\s+\S+\s+\S+\s+(\S+)" & @CRLF & _
"Ouput 2:" & @CRLF & _
"OK" & @CRLF & _
"The Regex i tried "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")