use strict;
my $str = 'Input 1:
Event: Started Flapping
Regex 1:
Output 1:
Started Flapping
Input 2:
Event: CRIT -> OK
Regex 2:
^Event:\\s+\\S+\\s+\\S+\\s+(\\S+)
Ouput 2:
OK
The Regex i tried ';
my $regex = qr/^Event:\s+(?|\S+\s+\S+\s+(\S+)|(Started Flapping))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}