// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^Event:\s+(?|\S+\s+\S+\s+(\S+)|(Started Flapping))$").unwrap();
let string = "Input 1:
Event: Started Flapping
Regex 1:
Output 1:
Started Flapping
Input 2:
Event: CRIT -> OK
Regex 2:
^Event:\\s+\\S+\\s+\\S+\\s+(\\S+)
Ouput 2:
OK
The Regex i tried ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}