package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^Event:\s+(?|\S+\s+\S+\s+(\S+)|(Started Flapping))$`)
var str = `Input 1:
Event: Started Flapping
Regex 1:
Output 1:
Started Flapping
Input 2:
Event: CRIT -> OK
Regex 2:
^Event:\s+\S+\s+\S+\s+(\S+)
Ouput 2:
OK
The Regex i tried `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}