const regex = /^Event:\s+(?|\S+\s+\S+\s+(\S+)|(Started Flapping))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Event:\\s+(?|\\S+\\s+\\S+\\s+(\\S+)|(Started Flapping))$', 'gm')
const str = `Input 1:
Event: Started Flapping
Regex 1:
Output 1:
Started Flapping
Input 2:
Event: CRIT -> OK
Regex 2:
^Event:\\s+\\S+\\s+\\S+\\s+(\\S+)
Ouput 2:
OK
The Regex i tried `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}