re = /^Event:\s+(?|\S+\s+\S+\s+(\S+)|(Started Flapping))$/m
str = 'Input 1:
Event: Started Flapping
Regex 1:
Output 1:
Started Flapping
Input 2:
Event: CRIT -> OK
Regex 2:
^Event:\\s+\\S+\\s+\\S+\\s+(\\S+)
Ouput 2:
OK
The Regex i tried '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end