import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Event:\\s+(?|\\S+\\s+\\S+\\s+(\\S+)|(Started Flapping))$";
final String string = "Input 1:\n"
+ "Event: Started Flapping\n\n"
+ "Regex 1:\n\n"
+ "Output 1:\n"
+ "Started Flapping\n\n"
+ "Input 2:\n"
+ "Event: CRIT -> OK\n"
+ "Regex 2:\n"
+ "^Event:\\s+\\S+\\s+\\S+\\s+(\\S+)\n"
+ "Ouput 2:\n"
+ "OK\n"
+ "The Regex i tried ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}