#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)foo(?:\sbar)?(?:\sbaz)?|bar(?:\sbaz)?|baz"
Local $sString = "foo bar baz" & @CRLF & _
"foo baz bar" & @CRLF & _
"baz bar foo" & @CRLF & _
"foo bar" & @CRLF & _
"foo baz" & @CRLF & _
"bar baz" & @CRLF & _
"foo" & @CRLF & _
"bar" & @CRLF & _
"baz"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")