package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)foo(?:\sbar)?(?:\sbaz)?|bar(?:\sbaz)?|baz`)
var str = `foo bar baz
foo baz bar
baz bar foo
foo bar
foo baz
bar baz
foo
bar
baz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}