import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "foo(?:\\sbar)?(?:\\sbaz)?|bar(?:\\sbaz)?|baz";
final String string = "foo bar baz\n"
+ "foo baz bar\n"
+ "baz bar foo\n"
+ "foo bar\n"
+ "foo baz\n"
+ "bar baz\n"
+ "foo\n"
+ "bar\n"
+ "baz";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}