const regex = /foo(?:\sbar)?(?:\sbaz)?|bar(?:\sbaz)?|baz/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('foo(?:\\sbar)?(?:\\sbaz)?|bar(?:\\sbaz)?|baz', 'gm')
const str = `foo bar baz
foo baz bar
baz bar foo
foo bar
foo baz
bar baz
foo
bar
baz`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}