# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<\\/body>(?![\s\S]*<\\/body>[\s\S]*$)/<tag\/>/i;t' <<< "<html>
<body>
</body>
</html>
<html>
<body>
</body>
</html>"