$re = '/<\/body>(?![\s\S]*<\/body>[\s\S]*$)/i';
$str = '<html>
<body>
</body>
</html>
<html>
<body>
</body>
</html>';
$subst = "<tag/>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;