const regex = /<\/body>(?![\s\S]*<\/body>[\s\S]*$)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\\/body>(?![\\s\\S]*<\\\/body>[\\s\\S]*$)', 'i')
const str = `<html>
<body>
</body>
</html>
<html>
<body>
</body>
</html>`;
const subst = `<tag/>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);