using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\/body>(?![\s\S]*<\/body>[\s\S]*$)";
string substitution = @"<tag/>";
string input = @"<html>
<body>
</body>
</html>
<html>
<body>
</body>
</html>";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}