use strict;
my $str = '<html>
<body>
</body>
</html>
<html>
<body>
</body>
</html>';
my $regex = qr/<\/body>(?![\s\S]*<\/body>[\s\S]*$)/ip;
my $subst = '<tag/>';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";