$re = '/^(?P<machinenr>[^\|]*?)\|
(?P<controldone>[^\|]*?)\|
(?P<nrofitems>[^\|]*?)\|
(?P<items>[^\|]*?)\|$/x';
$str = '446408|0|1|111|446408|0|3|99884|111|73732|446408|0|0||';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);