re = /^(?P<machinenr>[^\|]*?)\|
(?P<controldone>[^\|]*?)\|
(?P<nrofitems>[^\|]*?)\|
(?P<items>[^\|]*?)\|$/x
str = '446408|0|1|111|446408|0|3|99884|111|73732|446408|0|0||'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end