import re
regex = re.compile(r"""
^(?P<machinenr>[^\|]*?)\|
(?P<controldone>[^\|]*?)\|
(?P<nrofitems>[^\|]*?)\|
(?P<items>[^\|]*?)\|$
""", flags=re.VERBOSE)
test_str = "446408|0|1|111|446408|0|3|99884|111|73732|446408|0|0||"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")