using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z_]\w*?)=(\d+|""[^""]*"")( |$)";
string input = @"a=123 b=""ABC"" c=""Olá Mundo!""
var1=123 var2=""ABC"" hello_world=""Olá Mundo!""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}