re = /([a-zA-Z_]\w*?)=(\d+|"[^"]*")( |$)/m
str = 'a=123 b="ABC" c="Olá Mundo!"
var1=123 var2="ABC" hello_world="Olá Mundo!"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end