$re = '/([a-zA-Z_]\w*?)=(\d+|"[^"]*")( |$)/m';
$str = 'a=123 b="ABC" c="Olá Mundo!"
var1=123 var2="ABC" hello_world="Olá Mundo!"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);