package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-zA-Z_]\w*?)=(\d+|"[^"]*")( |$)`)
var str = `a=123 b="ABC" c="Olá Mundo!"
var1=123 var2="ABC" hello_world="Olá Mundo!"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}