import re
regex = re.compile(r"([a-zA-Z_]\w*?)=(\d+|\"[^\"]*\")( |$)", flags=re.MULTILINE)
test_str = ("a=123 b=\"ABC\" c=\"Olá Mundo!\"\n\n"
"var1=123 var2=\"ABC\" hello_world=\"Olá Mundo!\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")