// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)([a-zA-Z_]\w*?)=(\d+|"[^"]*")( |$)"#).unwrap();
let string = "a=123 b=\"ABC\" c=\"Olá Mundo!\"
var1=123 var2=\"ABC\" hello_world=\"Olá Mundo!\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}