# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^img.php\\/(https?):\\/+(.+?(?:\.jpg|\.png))\\/(\d+)\\/(\d+)\\/(\d+)\\/?([^\\/]*)\\/?([^\\/]*)\\/?([^\\/]*)$/img.php?src=$1:\/\/$2&w=$3&h=$4&q=$5&$6&$7&$8/;t' <<< "img.php/http://example2.com/img1.jpg/600/800/60/sharpen/crop-to-fit"