import Foundation
let pattern = #"^img.php\/(https?):\/+(.+?(?:\.jpg|\.png))\/(\d+)\/(\d+)\/(\d+)\/?([^\/]*)\/?([^\/]*)\/?([^\/]*)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"img.php/http://example2.com/img1.jpg/600/800/60/sharpen/crop-to-fit"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"img.php?src=$1://$2&w=$3&h=$4&q=$5&$6&$7&$8"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}