// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^img.php\/(https?):\/+(.+?(?:\.jpg|\.png))\/(\d+)\/(\d+)\/(\d+)\/?([^\/]*)\/?([^\/]*)\/?([^\/]*)$").unwrap();
let string = "img.php/http://example2.com/img1.jpg/600/800/60/sharpen/crop-to-fit";
let substitution = "img.php?src=$1://$2&w=$3&h=$4&q=$5&$6&$7&$8";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}