$re = '/^img.php\/(https?):\/+(.+?(?:\.jpg|\.png))\/(\d+)\/(\d+)\/(\d+)\/?([^\/]*)\/?([^\/]*)\/?([^\/]*)$/';
$str = 'img.php/http://example2.com/img1.jpg/600/800/60/sharpen/crop-to-fit';
$subst = "img.php?src=$1://$2&w=$3&h=$4&q=$5&$6&$7&$8";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;