use strict;
my $str = 'img.php/http://example2.com/img1.jpg/600/800/60/sharpen/crop-to-fit';
my $regex = qr/^img.php\/(https?):\/+(.+?(?:\.jpg|\.png))\/(\d+)\/(\d+)\/(\d+)\/?([^\/]*)\/?([^\/]*)\/?([^\/]*)$/p;
my $subst = 'img.php?src=$1://$2&w=$3&h=$4&q=$5&$6&$7&$8';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";