#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^img.php\/(https?):\/+(.+?(?:\.jpg|\.png))\/(\d+)\/(\d+)\/(\d+)\/?([^\/]*)\/?([^\/]*)\/?([^\/]*)$"
Local $sString = "img.php/http://example2.com/img1.jpg/600/800/60/sharpen/crop-to-fit"
Local $sSubst = "img.php?src=$1://$2&w=$3&h=$4&q=$5&$6&$7&$8"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)