using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^img.php\/(https?):\/+(.+?(?:\.jpg|\.png))\/(\d+)\/(\d+)\/(\d+)\/?([^\/]*)\/?([^\/]*)\/?([^\/]*)$";
string substitution = @"img.php?src=$1://$2&w=$3&h=$4&q=$5&$6&$7&$8";
string input = @"img.php/http://example2.com/img1.jpg/600/800/60/sharpen/crop-to-fit";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}