# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:[1-9][0-9]{3}|[1-9][0-9]{2}|[1-9][0-9]|[1-9])$//gm;t' <<< "9999
5446
1
2
12
99
100
0
1234
9999
10000
"